IMPORTANT: AIM 7.5 and below are no longer available and are no longer supported. If you are unable to connect to AIM you must download AIM 8 using the links below. We recommend that you uninstall the old version of AIM from your computer before downloading the new version using the links above.

If you are logging in to AIM 7.5 or an earlier version and see an error message like the one below, this is an indicator that you must upgrade to the latest version of AIM to continue using the service.

error message
 

To check if you are on the latest version AIM 8:

Windows users:
  1. Launch AIM.
  2. Click the Help button.
  3. Click About AIM.
  4. The latest version is AIM 8.x.

    verify aim version

Mac users:
  1. Launch AIM.
  2. Click the AIM button in the upper-left corner of the screen.
  3. Click About AIM.

    check aim version on mac

  4. The latest version is AIM 8.x.

To uninstall your old version of AIM:

  1. Open the Control Panel.
  2. Go to Add / Remove Programs or Programs and Features depending on your version of Windows.
  3. Find AIM 7 in the list and right click on it.  Select Uninstall.

    User-added image
    Note: AIM for Windows is the latest version of AIM.


For more instructions on how to uninstall your old version of AIM, please refer to our help article AIM for Desktop: Install / Uninstall FAQs.


AIM is also available on mobile devices running Android and iOS. Refer to the links below to download AIM Mobile for Android and iOS.